Back to overview
Resolved
Delays in processing calls
Jul 7, 2026 at 8:08pm UTC
Affected services
Call Processing
Resolved
Jul 7, 2026 at 10:14pm UTC
This incident has been resolved. The remaining calls have been processed as expected, and new calls are being processed on schedule.
Affected services
Updated
Jul 7, 2026 at 8:39pm UTC
We’ve identified the issue and implemented a solution. Calls are now being processed again. We’ve created a list of queued calls that will be processed first. We’ll update this page soon.
Affected services
Created
Jul 7, 2026 at 8:08pm UTC
We’re experiencing a delay in processing a portion of calls made by our bot or previously recorded calls. We’re actively investigating the issue and will promptly update this page with more information.
Affected services