Back to overview
Resolved
Delays in processing calls
Apr 29, 2026 at 3:35pm UTC
Affected services
Call Processing
Resolved
Apr 29, 2026 at 4:32pm UTC
This incident has been resolved. Calls are processing at the expected velocity.
Affected services
Created
Apr 29, 2026 at 3:35pm UTC
We're seeing a delay in processing some calls. We identified the issue which is related to a third-party provider. We'll keep this report updated.
This incident is currently affecting Bot recordings, HubSpot and uploaded calls
Affected services