Delays in processing some calls
Resolved
Apr 15, 2026 at 5:34pm UTC
Our systems have returned to their expected performance, and calls are now processing normally.
Affected services
Updated
Apr 15, 2026 at 5:13pm UTC
We’re almost done processing all the calls from the past two hours. We expect to normalize the processing in about 15 minutes. The recent calls are processing much faster.
Affected services
Updated
Apr 15, 2026 at 2:30pm UTC
We’ve identified that a third-party provider is causing a delay in processing call reports, resulting in a 10 to 30-minute processing time for calls. We’re actively working on reducing this delay by exploring alternative solutions. We’ll provide more updates soon.
Affected services
Created
Apr 15, 2026 at 1:47pm UTC
We are experiencing an increase in processing delays for calls recorded by the AI Coach bot. We are investigating the issue and will provide more information shortly.
Affected services