Back to overview
Degraded

Call processing is delayed

Mar 26, 2026 at 9:22pm UTC
Affected services
Call Processing

Resolved
Mar 26, 2026 at 10:16pm UTC

Call processing has fully recovered. All calls are being processed normally again. We're continuing to monitor to ensure stability.

Updated
Mar 26, 2026 at 9:40pm UTC

Error rates are improving and call processing is recovering. Approximately 15% of calls are still experiencing processing delays. We're actively monitoring and expect full recovery shortly.

Created
Mar 26, 2026 at 9:22pm UTC

We are seeing an increase in errors from one of our LLM providers. This is affecting the processing of new calls. You might see a delay in seeing calls in your dashboard. We'll keep this page updated once we have more information.