Back to overview
Resolved

Elevated errors impacting call reviews

Jun 12, 2025 at 6:54pm UTC
Affected services
Web Application

Resolved
Jun 12, 2025 at 8:46pm UTC

This incident has been resolved as our 3rd party providers are now stable and working as expected.

Updated
Jun 12, 2025 at 8:03pm UTC

Call processing is working as expected and we're seeing improving rates across other services. Some features are still affected such as some academy videos. We are monitoring their recovery.

Updated
Jun 12, 2025 at 7:02pm UTC

We are seeing some services coming back and calls are starting to get processed again. We're still monitoring the situation.

Created
Jun 12, 2025 at 6:54pm UTC

We're seeing an increased number of issues due to an outage from Google Cloud Platform which is impacting the process of call reviews. We're monitoring the situation and will provide the updates in this page.