Back to overview
Resolved

Delay processing calls

Sep 4, 2026 at 6:38pm UTC
Affected services
AI Roleplay
Global Insights
Call Processing

Resolved
Sep 4, 2026 at 8:04pm UTC

This issue has been resolved, and reports are being processed at the expected speed. We’ve completed the delayed reports, and new ones are being processed as usual.

Created
Sep 4, 2026 at 6:38pm UTC

We’re experiencing a delay in processing calls. We’ve identified that this issue is related to a third-party provider that’s impacting our processing. We’re collaborating closely with them to resolve the problem, and we’ll keep this page updated as soon as the issue is resolved.